SMS Services

Incident Report for Gordon Delivery

Resolved

This incident has been resolved.
Posted Sep 18, 2024 - 15:23 CEST

Investigating

Our SMS Supplier reports current and ongoing issues with the SMS Delivery Service.
This can affect several of our services.

We will continue to track the issue until it is fully resolved and will continuously keep you informed about the progress.
Posted Sep 18, 2024 - 12:13 CEST
This incident affected: Gordon Last Mile Platform and Gordon Driver App.