The issue has been identified and a fix is being implemented.
Posted Nov 14, 2023 - 15:24 CET
Investigating
We are currently experiencing some performance issues with our platform which may result in slower response times and occasional delays. Our technical team is actively working to identify and resolve these issues as quickly as possible.
Posted Nov 14, 2023 - 14:18 CET
This incident affected: Gordon Last Mile Platform, Gordon API, Gordon Driver App, and Gordon Tracking Page.