The system has long response times

Incident Report for Gordon Delivery

Resolved

This incident has been resolved.
Posted Sep 03, 2024 - 15:59 CEST

Investigating

We are currently investigating this issue.
Posted Sep 03, 2024 - 14:53 CEST
This incident affected: Gordon Last Mile Platform, Gordon API, Gordon Driver App, and Gordon Tracking Page.